The Sims 4

The Sims 4: How to fix Gallery UI issues caused by Mods

The Sims 4’s latest update has redesigned the way The Gallery looks and functions. Because of it heavily scripted mods (such as the UI Extension Mod) can affect your gameplay experience or even lead to UI errors and game crashes.

One of the things that many have reported is an issue where friends, followers and downloads on your personal profile would go “000000” and sometimes even your screen would go black after browsing through the gallery. It has been confirmed that this issue is caused by Mods (specifically UI Extension Mod) but it can be solved.

Removing the mods from your Mods folder and / or updating them to the latest verseion doesn’t always do the trick though. To fully fix The Gallery UI issues go to Electronic Arts > The Sims 4 save game folder and delete a cache file called “localthumbcache.package”. This is a cache file which regenerates after opening up The Sims 4 again so you don’t have to worry if it’s going to affect your game or not.

About the author

Jovan Jovic

Founder of the Sims Community website. I do plenty of things around here including writing articles such as "Top 10 Disney Princesses in The Sims", social media management, video content creation, streaming and more!


Click here to post a comment

This site uses Akismet to reduce spam. Learn how your comment data is processed.

  • I tried to follow you directions but…I don’t have a save game folder. Are you talking about the “saves” folder? if so, there is no “localthumbcache.package” inside that folder. I have a “localthumbcache.package” just inside the Sims 4 folder…I deleted that and updated to the newest UI mod and still got a UI LE. I didn’t freeze up like the first time though.

    • go to documents then electronic arts then sims 4 don`t go any furthere into any mods,just scroll down,down the road you will find the localthumbcache.package file

  • But we don’t know what exactly is causing the grayed out screen. It wasn’t UI Cheats, MC Command Center is stated to be fine, and it can’t be pose player or teleport any sim. Just like Rena, I’m still getting a UI LE. I keep getting and deleting localthumbcache but it doesn’t seem to help.