The Sims 4

The Sims 4 PC & Console: New Update + Patch Notes (June 4th 2020)

The Sims Team has released a brand new update for The Sims 4 on PC, Mac and Console!

To download the latest version of The Sims 4, simply open your Origin program and if the game doesn’t update automatically, right-click on The Sims 4 and select ”Update.” For console players, your game should update automatically however if it doesn’t simply go into the game options and you will be able to update from there.

For PC and Mac users – In case you have Mods or Custom Content, the game will automatically disable them for you after first launching The Sims 4 after the update. To re-enable all your Mods and Custom Content, select the Settings option in the menu and select Settings. Under the” Other” section you’ll find the ”Enable Custom Content and Mods” option. Check it and restart your game in order for it to take effect!

Update: A hotfix patch has also now been rolled out for console players. Patch notes have been updated to reflect all platforms.

Via EA.com

Update 06/04/2020

PC: 1.63.134.1020 / Mac: 1.63.134.1220

Console: Version 1.26

Hello Simmers,

We have a small but important update for you to address some critical issues that affect all players across PC and Mac. Thank you for your reports and assistance in tracking down these issues.

  • Fixed an issue in which the game crashed or quit upon loading game saves that were created prior to the June 3rd update.
  • Fixed an issue in which Error code 122:1c9cf40 would appear and loaded the Manage World screen and prompted Simmers to restart the game.

 

About the author

Krista

Hey, I'm Krista! Long time Simmer and Sims Community Staff. You'll find me knitting a collection of Lil' Grim's because why not?

68 Comments

  • yeah i updated then started my game, almost immediately my computer desk with incense caught fire. firefighters show up automatically, great!:D aaand just stare at my lit desk and laugh and stand there talking amoungst themselves, all in the way so my sim cannot extinguish the fire lol i laughed so hard at this but at the same time they only gave me 2 simolions to replace it lol, i love you all, but this is a sick jokeXD

    • The patch has helped, but still am having issues. Still cannot open the gallery, cannot come out of build mode to game mode and my sims whims and emotions are just blank boxes still need some sorting please ❤️

      • If you use mods remove them. The issues you mention sound like mod incompatibility issues

      • I’ve noticed that UI cheats extensions has been causing the gallery to not open or if it does it’s just nothingness filled with w’s

        • When I awoke this morning I found out a update was needed to my Sims 4. I updated to the 1.26 version only to get a loading screen that would soon pop up as an error after I picked my save household prior to the update. I just bought the university expansion pack two days ago… I just would like some assistance so, I can get my game back working or a solution to my problem. Thank you.

    • Try a different default eye set to see if it’s truly broken or just the original one you had. Some defaults are really old and need to be updated. If that’s the case there are tutorials around to create default eyes using sims4studio program. I’ve done this myself to convert a set that I wanted to be a default replacement for personal use only as it’s not my creation. Granted I did a sloppy job because I was more interested to test if I did it correctly.

  • What about console? I’m on console and I’ve heard this happened on there too. I’m afraid to go on and see if I’m a victim.

    • Its happening to all platforms but they only seem to care abt pc and mac and ps4 and xbox have the exact same problem but they haven’t seemed to adress that problem yet but for now none of us can play the sims

      • In the latest tweet, they said they are working on the problem with the consoles. It takes time. It can either be done right or be done fast but wrong.

    • Don’t play. Worse update ever. It keeps crashing. All of my photos are black and there’s no help because console gets 0 support.

  • I updated my game again but No Trespassing and Toddler Styles are still not there or working… Anyone else?

  • I don’t know if it’s my mods or the game but it loads fine but in game i cannot click anything and it stays on pause. .
    great update
    im so frustrated im taking a break from the game.

    • Maybe you figured this out already, but if you have UI cheats mod, either remove it or update it from the creator – that solved this issue for me

    • Outdated mods. C’mon people, if you won’t be responsible for keeping mods updated do not use them

    • mine updated a few minutes ago ( I play on an Xbox console) and before this whole issue yesterday I bought a pack from the sale (Realm of Magic) it was going fine until my game crashed and it won’t let me into that specific gameplay and it tells me to “rEsTarT ThE gAmE” and when i do it nothing changes it never does this so why now? when you do updates make sure it’s worth our time because us console players and others have spent so much of our money on this game which is supposed to be fun and relaxing to play. It lets me play my other gameplay but I didn’t try all of the other ones yet I get bored playing with just one family if you understand where i’m coming from :)

  • Does anyone know when I will be able to buy the eco pack in a bundle as I already have all of the other expansion packs and it won’t let me and I want to get eco lifestyle but I want to wait and bundle it!

  • The patch has helped, but still am having issues. Still cannot open the gallery, cannot come out of build mode to game mode and my sims whims and emotions are just blank boxes still need some sorting please ❤️

  • My game sounds/ music doesn’t work. I haven’t got any mail, except for bills once a week. Fire from toilet when in use. I’m on xbox

  • I still cannot access the gallery. It comes up blank with its tabs filled with the letter ‘W’ and after I close it and try to reopen, it wont reopen at all.

  • My sims 4 updated as soon as i went on to my origin and now i can’t play the game…. it’s stuck on the loading screen(loading tips www) the sims 4 digital deluxe pack update

  • Congrats sims, I now have to turn auto updates off for my games because I can’t trust them. From now on I’m going to read from players before updating your game

  • Besides the correction of those errors, does anyone know if some other errors will be corrected with this update? If yes, which ones?

    Ty ;)

  • After the update i immediately wanted to play but it seems like i can’t because i can’t seem to see my households like there pictures and i can’t even play if i press play it does nothing then i uninstalled the sims 4 and then installed it again but it’s the same thing i can’t play my game i even repaired it but nothing helped i removed mods everything still nothing at this rate i won’t be able to play the sims 4 ever again

  • When I go into gas my sim is black white and red with question makes all over it and when I tried to change what they were wearing my sims just disappeared. Also a lot of my base game object including things like pool water turn rainbow with questions marks and whenever I place tvs they disappear how do I fix this I literally my whole entire game is broken after the new update

  • Can anyone help? My daughter plays SIMS4 on my laptop, which is new and up to date. Suddenly SIMS4 won’t launch. It gets stuck on teh second startup page (the blue one with the daily tip). She has been downloading MODS and everything was fine until 2 days ago. She downloaded Discord but that didn’t work and caused a Javascript error. We finally managed to get rid of Discord but now we get an error message saying the video card is out of date, even though it’s been updated. The games still gets stuck on the startup page. I’ve been to EA chat online and I’ve done the repair game and clear cache option but nothing. They said they are aware of an issue and are working on a fix but I want to make sure it’s an issue their end not ours.

  • After installing this expansion pack, this erros keeps showing up:
    109:812fe7cb:ceb204aa
    I can’t enter any of my families ..

  • I play on PS4 and ever since my game updated it keeps saying I need to relaunch the game every time I want to go back to my home and it loads me in after the second time. Someone help please

  • I was playing the game like normal, enjoying eco-living, and decided I wanted to place a restaurant down so I could go on a date with someone. I didn’t have any problems up until this point. I placed the lot and fixed stuff on it and then went to go and play my sim while she was still at her house. When I clicked to play the household, it would go to the loading screen and then the audio would cut out and the plum bob would freeze, and then the game would shut down for no reason. I tried deleting the restaurant but it still happened. I repaired my game and made sure all my mods were updated and still the same thing. Then I removed my mods all together and it still did the same freeze and cut off. Any suggestions?

  • Probably a stupid question but can someone please tell me how I rotate a sim in cas on Xbox? Since the update I cannot do it how a used to!

  • since having the update and downloading eco pack for ps4, I have controls instructions on my right hand side of screen below notifications. I cant get them off my screen!!! Bugging me.

    Says things like select, hold + left stick to pan camera, decrease/increase game speed etc. Why can i not get this off the screen i hope its not permanent.

  • Play xbox here and the sounds is messed up and all static! I’m so disappointed because I always play console so no mods and just assume gameplay will always go smooth. I have fountains and they sound like hellish static and regular game sounds glitch as well. :(

  • damn this update really messed things up when it came to Wicked WooHoo badly which is rare seeing as this never happened before, I guess that is what happens when a new pack comes out and not everything is expected to work like it should.

  • My sims 4 still isn’t working properly. It still tells me there has been an error, (134:c8640a95:5aee4535) and I updated my ps4 and sims4. I deleted my sim households that didn’t work and I’m trying to make a new sim but it won’t let me move around or anything. This morning it wouldn’t let me open up the gallery or anything but now it is. But why can’t I move around in Cas mode???

    • I have the exact problem and its driving me mad. My son so badly wants to play with the new packs that we bought him for his birthday but we cant.

  • Error code 134:c8640a95:5aee4535. It goes into the world but when we click play on our house this error code appears everytime we want to play. Please help. Playing on xbox one

  • Since the new update I can’t play my favorite household. The game tells me to relaunch after an error. Also my sims are wearing clothes I did not put them on. Other sims in the games are not fully dress and the ones that are seems to be broken throughout my entire game. I do not like playing the game anymore after the June 2020 update. I spent 6 months with that family and my home game is base on that family. I can’t play them but it is hard to delete them.

Leave a Comment

This site uses Akismet to reduce spam. Learn how your comment data is processed.