The Sims 4

The Sims 4 PC / Mac: New Update + Patch Notes! (January 16th, 2020)

The Sims Team has released a brand new Update for The Sims 4 on PC and Mac!

To download the latest version of The Sims 4, simply open your Origin program and if the game doesn’t update automatically, right click on The Sims 4 and select ”Update”.

In case you have Mods or Custom Content, the game will automatically disable them for you after first launching The Sims 4 after the update. To re-enable all your Mods and Custom Content, select the Settings option in the Menu and select Settings. Under the”Other” section you’ll find the ”Enable Custom Content and Mods” option. Check it and restart your game in order for it to take effect!

Patch Notes

Update 01/16/2020 – PC: 1.60.54.1020 / Mac: 1.60.54.1220

Hello Simmers! Hope you all had a fantastic holiday season.

In today’s update we welcome you all to The Sims™ 4 Tiny Living Stuff pack; where your goal is to build the most comfortable space within the smallest footprint possible. Stretch your imaginative muscles as you figure out creative ways to cram in all you need! How low can you go?!

Besides preparing us for Tiny Living, in this update we have addressed a few issues as well as we have set aside quite some time for a new addition in our language roster, we are happy to announce that The Sims™ 4 is now supported in Simplified Chinese! We are very excited to release this to the public and further connect with Simmers in different languages across the world!

-SimGuruNinja, Ft. SimGuruRusskii

FIXES & UPDATES

The Sims 4

  • Fixed an issue in which Hygiene was not being resolved when Taking a Shower on any Bathtub and Shower Combo.
  • Fixed an issue in which the game would jump to Ultra Speed randomly when some Service NPC, specifically Maids, were on the Lot. Talk about speed cleaning!
  • Resolved an issue related to Traveling that resulted in Error Codes: 109:8c87f108 and 106:69b9523b.
  • Photo frames used within Gallery Uploads would not retain their chosen color once those lots were downloaded from The Gallery. They’ve been properly chastised and will listen to you now.
  • Freelancer gigs can now complete and/or update accordingly while on Vacation. So if you want to work while you vacay I guess you can now. Sucker.
  • Burned no longer The Child Statue (sculptTableMedium_EF22GENchild01_set1) will be.
    • Inventory can be also be placed in, and live draggable no longer can be.
  • Fixed an issue where two “Tuck In” interactions were able to be selected when Children slept on any bed. Kids – so needy, amirite?

Get Together

  • Toddlers will now route appropriately when selecting ‘Plan Outfit’ on Closets. Well, as appropriately as those slow little Sims move anyway.

Seasons

  • Solved an issue with swimwear yfBody_EP05SwimRetro_PinkGreen that made it display incorrectly in certain Graphics Quality Settings. And no one wants a swimsuit malfunction!

Get Famous

  • Actor Sims can now Check Open Auditions properly when returning from Work. Get that bread! Be a starving artist no more!
  • Sims’ Acting Gigs Career Panel will now get updated properly on performing tasks. Credit for your work? Imagine that!

Discover University

  • Sims will no longer see the option to remove Robo Arm when choosing to remove Computer Glasses.
  • Fixed an issue in which the option to Pay Student Loans was available even though students had enough Simoleons to cover their Tuition.
  • Sims can now be warned about losing scholarships if they choose to withdraw from the term. And they’re lucky to get a warning! Expel ‘em, I say (they don’t listen to me, though)!
  • Some lots were unloadable in Britechester and made the game unresponsive. That should no longer be the case.

Outdoor Retreat

  • A visual issue was resolved where highlighting the Granite Falls Blossom would result in a strange texture.This however only was affecting Simmers who had StrangerVille installed as well.

Dine Out

  • Food was sometimes not able to be ordered or delivered when the game was exited or reloaded from the Main Menu. But a Sim’s gotta eat after all, so we’ve fixed it.

Realm of Magic

  • Two ‘Inferniate’ interactions display on some rugs. As much as some hate those rugs’ patterns, only one ‘Inferniate’ is more than enough.

Laundry Day

  • Clothes moved to the clothing line to dry were not getting dry. We’ve reduced the moisture in the air and it should work now.

Moschino

  • yfHair_SP15SlickedBackLong was displaying with a grey line. “Not that there’s anything wrong with a little gray,” says SimGuruNinja reflectively touching his hair.
  • “Take Photo Of” was allowed to target unmet NPC Sims. Creepy and awkward for sure. Go meet them first for goodness sake like a normal human.
  • Freelance Photographer Sims can now see all proper tasks for gigs ‘Genius Professor Outdoor Wear Study’ and ‘Everyday Activities Fashion Shoot.’ So no more excuses for any future lackluster job performance!
  • Freelance Fashion Photography Gigs ‘Finding the Essence of Efficiency with Everyday Style’ and ‘Fantastic Formula for Formal Style’ now display correct information for Pay, Due Date, and/or Required Skill Level.
  • The Amp Stack (stereoFloor2x1_SP15GEN) now functions as a Stereo, living to its full potential. Rock on!
  • Burnt photos would not be charred anymore once placed outside Sims’ inventory. We’ve burnt them all to a crisp and they’ll appear correctly now.

About the author

Jovan Jovic

Founder of the Sims Community website. I do plenty of things around here including writing articles such as "Top 10 Disney Princesses in The Sims", social media management, video content creation, streaming and more!

74 Comments

Click here to post a comment

This site uses Akismet to reduce spam. Learn how your comment data is processed.

  • Was there anything else? Since this technically doesn’t list the new upgrade options for the bed I was wondering if there was anything else new that hasnt been mentioned here..

    • Since this update my game is so messed up. Build mode doesn’t work or open and the gallery won’t let me place anything. I have to shut down the whole game if I try to open either one, because I have no option to close them and return to game mode.

      • I have this exact same problem but only with build mode, and for some reason it only happens to me, my sister says it doesn’t happen to her when she plays…and she’s playing on the same computer as me.

      • This update messed up my game I can’t decorate in build mode( nothing shows up bottom or top of screen), also I can’t return to live mode once in build mode. FIX IT!

        • Experiencing the exact same thing! I thought I’d finally got it to work so I tested our creating a family to move in and as soon as I moved them in to Crick Cabana they completely disappeared! They’re not even in my saved households… so upset about this update!!!

      • I’m having the same issue Erica and it’s awful. So many things are messed up for me too, especially build mode and that’s driving me insane. It’ll open blank, then say “to go back to live mode select manage worlds” and it’s just a constant broken loop. UGH I hope they fix this soon.

    • me either, has anyone worked out how to fix it yet. driving me nuts!! my kids computer is fine its just mine. no build mode menu at all, have to save game, go out and go back in to play again

      • Same!! Build mode is completely blank and it’s driving me NUTS! I’ve spent hours trying to fix it and nothing works omg. I can’t believe it’s because of this new update! >:(

      • Omg I deleted my UI cheats and it worked, my game is still a liiittle bit slow but it works now, thank you so much for the tip.

  • I love now when eating at a restaurant when after you sim finishes the drink it will stop eating and then you’ll have to continue to sequence, instead of the Sim being a big boy and doing it all on his own.

    • Sim’s are like adult babies, you need to gently hold their hand and make “Choo-Choo” noises as you sit them down and present them with food after a hydrating sip of water

  • Anyone else experiencing problems with dining out where sims will not finish their meal after they drink their beverages?

  • After updating my game to get the patch the build mode menus (the top and bottom menu with the ideas) don’t show up. I can move and delete items but I can’t buy/build because the menus aren’t there. I tried resizing my game and it didn’t help. I’m not sure if it’s because of the patch or just a glitch, I just know that this happened after updating my game. Live mode menus appear normally and work just find, it’s just build mode. Is it just me?

    • Same here, Im in the middle of trying to figure it out…I really dread having to do the 50/50 thing, as my mods folder is over 16 gigs.

    • Same here if I enter build nothing shows up and you can’t exit build mode only exit the game. Also I can’t move around with my mouse only the arrow keys on the keyboard. I removed all my mods and have the same problem.

      • I removed all the mods and turned off cc and mods and script mods allowed in the setup restarted the game and got build mode to work right. I have been updating all my mods a little at a time so far build mode still works and I got the mouse working right too.

  • May I ask who wrote this line in the patch notes at EA? Master Yoda?? I mean this doesn’t make a bit of sense at all.
    “Inventory can be also be placed in, and live draggable no longer can be.”

  • Anyone having problems with with build mode since the new update 1/16/20? I enter build mode but nothing comes up and you can’t get out of build mode only exit the game.

  • Every since the Sims 4 January 16th 2020 update.Origin is completely blank i can not do anything not even play Sims 4!!

  • Since the new update I can’t seem to get on to my world without having to have to buy an expansion pack :/ is this correct?

  • So we’re still dealing with multiplied notifications about foxbury spirit day. Every week I’m at foxbury I get one more notification for this event. I.e if I complete 4 weeks there I will be getting four notifications at once for the event. If I play generations, I’ve gotten up to 30 notifications at once.

  • My Sims 4 won’t even launch on my mac now with the new update. The last version worked fine! And now it doesn’t. Does anyone know why this is?

    • My Sims 4 also won’t launch on my Mac. It goes to a black screen and freezes the entire computer. I have a brand new MacBook. It worked fine before the update.

  • For everyone having issues with build mode not popping up after the update try to redownload and update your UI cheats mod. they have an update and once I downloaded it my game was fixed.

    Hope this helps :)

    • But there isn’t a newer version, the only new version is for the legacy edition and that’s not recommended if you don’t use the legacy version… The only recent version other than that is “UI_Cheats_Extension_v.1.12.zip | Description: Built with Game Version 1.50.67 | 22nd Feb 2019. This is from “Weerbesu” right? Unless there’s another one that’s out there, that’s all that’s posted by him.

  • I’m sad. Ever since the update I cannot edit any lots in build mode because it glitches and shows blanks then when i try to exit to game mode it takes me to edit town :/

  • Help.. After updating my game and launching the sims 4, it prompted me to re-enable mods/cc and after doing so, i exited the game and when i tried to launch again it wouldn’t open and keeps bringing me back to origin. when i took the mods/cc out, and it ran fine, but putting them back in it wont open anymore.
    Anyone else suffering in silence? Am i missing something? I feel a little slow.

  • My game is glitching so much after this update. My sims have questions marks on them and base game furniture is also glitching. (My sims don’t have custom content on them)

  • The update won’t let me play the game… I’ve restarted my computer 2 times, and nothing happened. I tried to create a new Sim and I was unable to customize it. When I clicked continue to build the house, the screen stayed on the loading screen. Nothing happened. Then I went to load my old Sim and it ended up saving 2,000 files for the new Sim I tried to make. This update isn’t letting me to anything…. Please advise on what to do to correct this mess up
    Also when I load my old Sim, it pulls up a screen with different expansion packs. It’s like they are trying to get me to buy them. But I just want to play regular Sims 4. I want to buy an expansion pack, but that is something I need to save up for.
    Thanks,

  • I am having a different issue. I have no CC or Mods in my game. Just updated it, and there are tons of thumbnail images missing (the stuff packs in the menu screen, the Newcrest and San Myshuno World selection, some of the Lot Traits when you hover over a lot) that have been replaced with a gray llama image. When I did load a lot, some of my build mode objects, like a base game floor trim was, was colored a weird red and green pattern with a question mark on it.
    HELP ME!!!!

  • So I just updated my game today, and after the patch I noticed that build mode is not responsive at all. I can’t view the catalog, or place or move anything at all. Anyone else having this problem?

  • After update my game keeps crashing voiding me to loose everything I’ve just built I started to save a lot during builds but never had to do that before

  • For some reason, after this update, my game thinks I’m missing packs (just spa day) and the game keeps crashing when I try to split the family I’m playing and move them. I have no CC or mods installed. Anyone else having this issue? I own all the packs, tried uninstalling and reinstalling origin.. I’m the only use of my EA account.

  • After I downloaded the patch, I got even more glitches! A lot of the assets are not loading, and it isn’t due to custom content.

  • I am so very sick of this! I cannot play my game since this update. My game is frozen. Won’t do anything. Why is it so difficult for such a big company to have a seamless update without screwing everything up?! I’m sick of it! I don’t have a lot of time to play Sims 4 so when I do, I would actually like it to work. It was fine until this update. The tiles on the floor of the house are all question marks and my Sims won’t move around.

  • I can’t load my game at all anymore. It looks like it’s loading and starting to open and then it suddenly exits out. I have it through Origin if that changes anything. No pop-ups telling me what’s wrong or anything.

  • I’m pretty sure that the lates update did up date but every time I turn on my computer it comes up and only goes to an error I haven’t played my game in almost a month cause it won’t load my game is what relaxes me now it does nothing what do I do I can’t even get to origin it doesn’t even recognize me what is going on

  • I’ve been having build mode issues myself. My game has been repaired three times now! Every time i delete an object in build mode i have to do it twice in order to get my money. Anyone else with this issue??

  • i had the same problem with the game freezing in build mode as others, but now i open the game and get to the loading screen that says the sims 4, and the game just closes. i’ve tried removing all my mods and all my cc but it still does it even without any mods or cc

  • I Just updated my sims4 on pc and all of my families are gone, all of my worlds are gone but the shopping area and the vacation spot.. what the hell is going on?